wymagania

releng-tool zostało zaprojektowane w języku Python i wymaga Python 2.7 lub 3.4+ aby działał w systemie hosta. W przypadku niektórych etapów czy funkcji, mogą być potrzebne opcjonalne narzędzia. Na przykład, projekty pobierające źródła z Git będą wymagały zainstalowania narzędzi git; projekty z łataniem będą wymagały narzędzia patch. Chociaż niektóre funkcje mogą działać na niektórych konkretnych systemach (np. funkcje autotools są przeznaczone do Linuxa), releng-tool może działać na kilku systemach operacyjnych.