要求

releng-tool 是在 Python 中开发的,需要 Python 2.7或3.4+ 才能在主机系统上运行。如果使用某些阶段和/或特征,则需要一系列可选工具。例如,从 Git 获取源的项目将需要安装 git 工具; 带修补程式的项目则需要 patch 工具。虽然某些功能可能是特定于操作系统的(例如 autotools 功能是为基于 Linux 的主机设计的),但 releng-tool 可以适用于各种操作系统变体。